summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2020-08-29 16:36:40 (GMT)
committerGitHub <noreply@github.com>2020-08-29 16:36:40 (GMT)
commit88b86a9752afc2c50ca196f6ba1a8d62d71cf398 (patch)
tree9a3f82c136625149cb55cd375dc158cd26fb6d35 /configure.ac
parentc01a7edc67e2c2e13a6d9513f111f27761786e27 (diff)
downloadcpython-88b86a9752afc2c50ca196f6ba1a8d62d71cf398.zip
cpython-88b86a9752afc2c50ca196f6ba1a8d62d71cf398.tar.gz
cpython-88b86a9752afc2c50ca196f6ba1a8d62d71cf398.tar.bz2
bpo-19521: Fix parallel build race condition on AIX (GH-22001)
Patch by Michael Haubenwallner. (cherry picked from commit e6dcd371b2c54a94584dd124e8c592a496d46a47) Co-authored-by: Stefan Krah <skrah@bytereef.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 18 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 7bbceb1..1bcd41e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1024,21 +1024,12 @@ LDVERSION="$VERSION"
# If CXX is set, and if it is needed to link a main function that was
# compiled with CXX, LINKCC is CXX instead. Always using CXX is undesirable:
# python might then depend on the C++ runtime
-# This is altered for AIX in order to build the export list before
-# linking.
AC_SUBST(LINKCC)
AC_MSG_CHECKING(LINKCC)
if test -z "$LINKCC"
then
LINKCC='$(PURIFY) $(MAINCC)'
case $ac_sys_system in
- AIX*)
- exp_extra="\"\""
- if test $ac_sys_release -ge 5 -o \
- $ac_sys_release -eq 4 -a `uname -r` -ge 2 ; then
- exp_extra="."
- fi
- LINKCC="\$(srcdir)/Modules/makexp_aix Modules/python.exp $exp_extra \$(LIBRARY); $LINKCC";;
QNX*)
# qcc must be used because the other compilers do not
# support -N.
@@ -1047,6 +1038,24 @@ then
fi
AC_MSG_RESULT($LINKCC)
+# EXPORTSYMS holds the list of exported symbols for AIX.
+# EXPORTSFROM holds the module name exporting symbols on AIX.
+EXPORTSYMS=
+EXPORTSFROM=
+AC_SUBST(EXPORTSYMS)
+AC_SUBST(EXPORTSFROM)
+AC_MSG_CHECKING(EXPORTSYMS)
+case $ac_sys_system in
+AIX*)
+ EXPORTSYMS="Modules/python.exp"
+ if test $ac_sys_release -ge 5 -o \
+ $ac_sys_release -eq 4 -a `uname -r` -ge 2 ; then
+ EXPORTSFROM=. # the main executable
+ fi
+ ;;
+esac
+AC_MSG_RESULT($EXPORTSYMS)
+
# GNULD is set to "yes" if the GNU linker is used. If this goes wrong
# make sure we default having it set to "no": this is used by
# distutils.unixccompiler to know if it should add --enable-new-dtags