summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authordoko@ubuntu.com <doko@ubuntu.com>2012-06-30 12:42:46 (GMT)
committerdoko@ubuntu.com <doko@ubuntu.com>2012-06-30 12:42:46 (GMT)
commit51f6594054c9c35bad92a8c488692766a180cbdd (patch)
tree66c0c7e45ca42199c3ee695bac72b2a8cadc978a /configure.ac
parent93df16bb16ba6677955acb9985c439dcbb546a89 (diff)
downloadcpython-51f6594054c9c35bad92a8c488692766a180cbdd.zip
cpython-51f6594054c9c35bad92a8c488692766a180cbdd.tar.gz
cpython-51f6594054c9c35bad92a8c488692766a180cbdd.tar.bz2
- Issue #3754: Use AC_PATH_TOOL and AC_CHECK_TOOLS instead of
AC_PATH_PROG and AC_CHECK_PROGS for the target tools.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index d05e1bc..16b20f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -608,9 +608,9 @@ preset_cxx="$CXX"
if test -z "$CXX"
then
case "$CC" in
- gcc) AC_PATH_PROG(CXX, [g++], [g++], [notfound]) ;;
- cc) AC_PATH_PROG(CXX, [c++], [c++], [notfound]) ;;
- clang|*/clang) AC_PATH_PROG(CXX, [clang++], [clang++], [notfound]) ;;
+ gcc) AC_PATH_TOOL(CXX, [g++], [g++], [notfound]) ;;
+ cc) AC_PATH_TOOL(CXX, [c++], [c++], [notfound]) ;;
+ clang|*/clang) AC_PATH_TOOL(CXX, [clang++], [clang++], [notfound]) ;;
esac
if test "$CXX" = "notfound"
then
@@ -619,7 +619,7 @@ then
fi
if test -z "$CXX"
then
- AC_CHECK_PROGS(CXX, $CCC c++ g++ gcc CC cxx cc++ cl, notfound)
+ AC_CHECK_TOOLS(CXX, $CCC c++ g++ gcc CC cxx cc++ cl, notfound)
if test "$CXX" = "notfound"
then
CXX=""
@@ -916,7 +916,7 @@ AC_MSG_RESULT($LDLIBRARY)
AC_PROG_RANLIB
AC_SUBST(AR)
-AC_CHECK_PROGS(AR, ar aal, ar)
+AC_CHECK_TOOLS(AR, ar aal, ar)
# tweak ARFLAGS only if the user didn't set it on the command line
AC_SUBST(ARFLAGS)