summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBrett Cannon <brettcannon@users.noreply.github.com>2017-06-09 20:56:57 (GMT)
committerGitHub <noreply@github.com>2017-06-09 20:56:57 (GMT)
commitb4e5fee6f5bcc50500ea6261a22021db58955b55 (patch)
tree1a1fd488136f18efcbcfd12bedb912b5b49f8311 /configure.ac
parent7be651c7aad8e4d46012205811b58ef127b08e0e (diff)
downloadcpython-b4e5fee6f5bcc50500ea6261a22021db58955b55.zip
cpython-b4e5fee6f5bcc50500ea6261a22021db58955b55.tar.gz
cpython-b4e5fee6f5bcc50500ea6261a22021db58955b55.tar.bz2
Clarify what --enable-optimizations does (GH-1847)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5aa52d3..d5b6399 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1277,7 +1277,7 @@ AC_SUBST(DEF_MAKE_ALL_RULE)
AC_SUBST(DEF_MAKE_RULE)
Py_OPT='false'
AC_MSG_CHECKING(for --enable-optimizations)
-AC_ARG_ENABLE(optimizations, AS_HELP_STRING([--enable-optimizations], [Enable expensive optimizations (PGO, etc). Disabled by default.]),
+AC_ARG_ENABLE(optimizations, AS_HELP_STRING([--enable-optimizations], [Enable expensive, stable optimizations (PGO, etc). Disabled by default.]),
[
if test "$enableval" != no
then
@@ -5469,7 +5469,7 @@ mv config.c Modules
if test "$Py_OPT" = 'false' -a "$Py_DEBUG" != 'true'; then
echo "" >&AS_MESSAGE_FD
echo "" >&AS_MESSAGE_FD
- echo "If you want a release build with all optimizations active (LTO, PGO, etc)," >&AS_MESSAGE_FD
+ echo "If you want a release build with all stable optimizations active (PGO, etc)," >&AS_MESSAGE_FD
echo "please run ./configure --enable-optimizations" >&AS_MESSAGE_FD
echo "" >&AS_MESSAGE_FD
echo "" >&AS_MESSAGE_FD