summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2022-05-13 07:00:33 (GMT)
committerGitHub <noreply@github.com>2022-05-13 07:00:33 (GMT)
commitc41667e71b6f1b0c9581160ccd82026738c3a736 (patch)
tree16d95ca86456c59be88277e0ba08cd862b20788a /configure.ac
parent715b070dcc17fc35bbc09f729354d7a05a8b2539 (diff)
downloadcpython-c41667e71b6f1b0c9581160ccd82026738c3a736.zip
cpython-c41667e71b6f1b0c9581160ccd82026738c3a736.tar.gz
cpython-c41667e71b6f1b0c9581160ccd82026738c3a736.tar.bz2
gh-90473: Increase stack size, disable obmalloc on WASI (GH-92732)
(cherry picked from commit d81d57e9598dea741e049f3876ccd87072a38906) Co-authored-by: Christian Heimes <christian@python.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 17 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c27d4ca..693f79b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1994,6 +1994,10 @@ AS_CASE([$ac_sys_system],
AC_DEFINE([_WASI_EMULATED_PROCESS_CLOCKS], [1], [Define to 1 if you want to emulate process clocks on WASI])
LIBS="$LIBS -lwasi-emulated-signal -lwasi-emulated-getpid -lwasi-emulated-process-clocks"
echo "#define _WASI_EMULATED_SIGNAL 1" >> confdefs.h
+
+ dnl increase initial memory and stack size, move stack first
+ dnl https://github.com/WebAssembly/wasi-libc/issues/233
+ AS_VAR_APPEND([LDFLAGS_NODIST], [" -z stack-size=524288 -Wl,--stack-first -Wl,--initial-memory=10485760"])
]
)
@@ -4046,13 +4050,17 @@ dnl the check does not work on cross compilation case...
#include <sys/types.h>
#include <sys/socket.h>]],
[[int domain = AF_INET6;]])],[
- AC_MSG_RESULT(yes)
ipv6=yes
],[
- AC_MSG_RESULT(no)
ipv6=no
])
+AS_CASE([$ac_sys_system],
+ [WASI], [ipv6=no]
+)
+
+AC_MSG_RESULT([$ipv6])
+
if test "$ipv6" = "yes"; then
AC_MSG_CHECKING(if RFC2553 API is available)
AC_COMPILE_IFELSE([
@@ -4232,9 +4240,10 @@ AC_ARG_WITH(pymalloc,
if test -z "$with_pymalloc"
then
- dnl default to yes except for wasm32-emscripten
+ dnl default to yes except for wasm32-emscripten and wasm32-wasi.
AS_CASE([$ac_sys_system],
[Emscripten], [with_pymalloc="no"],
+ [WASI], [with_pymalloc="no"],
[with_pymalloc="yes"]
)
fi
@@ -6680,7 +6689,11 @@ AS_CASE([$ac_sys_system],
)
],
[Emscripten/node*], [],
- [WASI/*], []
+ [WASI/*], [
+ PY_STDLIB_MOD_SET_NA(
+ [_ctypes_test],
+ )
+ ]
)
],
[PY_STDLIB_MOD_SET_NA([_scproxy])]