summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2003-01-20 10:47:48 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2003-01-20 10:47:48 (GMT)
commit0780e470dcba9d9b7307cbce7dcddd6053efaf53 (patch)
tree079a692b41c8403d09632445a41f6a9d43b25bad /configure.in
parent7a503a4ee6551cc7f19ced60121985f3c5116c43 (diff)
downloadcpython-0780e470dcba9d9b7307cbce7dcddd6053efaf53.zip
cpython-0780e470dcba9d9b7307cbce7dcddd6053efaf53.tar.gz
cpython-0780e470dcba9d9b7307cbce7dcddd6053efaf53.tar.bz2
On MacOSX, added -prebind option to link phase for executable (and
framework, if applicable). This speeds up startup time by up to 50%.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9ec081a..c8ba86b 100644
--- a/configure.in
+++ b/configure.in
@@ -1164,7 +1164,11 @@ then
# -u _PyMac_Error is needed to pull in the mac toolbox glue, which is
# not used by the core itself but which needs to be in the core so
# that dynamically loaded extension modules have access to it.
- LINKFORSHARED="$extra_undefs -framework System"
+ # -prebind causes the executable to assume dynamic libraries are at their
+ # preferred address, which speeds up startup. We specify it here
+ # in stead of in LDFLAGS because it does not seem to work for bundle
+ # plugins (as of OSX 10.2).
+ LINKFORSHARED="$extra_undefs -framework System -prebind"
if test "$enable_framework"
then
LINKFORSHARED="$LINKFORSHARED -framework Python"