summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2002-06-21 14:48:38 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2002-06-21 14:48:38 (GMT)
commit0b06be7b0be87bd78707a939cb9964f634f392d4 (patch)
tree67f36019aec912aa406a235b8f16fb3add8c64bf /configure.in
parent6f45eeb0f3258ee6482f0984622bcc1052ba36bd (diff)
downloadcpython-0b06be7b0be87bd78707a939cb9964f634f392d4.zip
cpython-0b06be7b0be87bd78707a939cb9964f634f392d4.tar.gz
cpython-0b06be7b0be87bd78707a939cb9964f634f392d4.tar.bz2
Patch #557719 by Tony Lownds, slightly massaged by me: streamline the
OSX framework build process. Things fixed/modified: - the filesystem case-sensitivity test now works for builds outside the source directory - various other fixes for building outside the source directory - python.app now has a target in the main Makefile - WASTE and AquaTk are found more automatically
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 5a53aab..eeab200 100644
--- a/configure.in
+++ b/configure.in
@@ -221,7 +221,7 @@ AC_MSG_RESULT($EXEEXT)
# case we give a warning if no ext is given
AC_SUBST(BUILDEXEEXT)
AC_MSG_CHECKING(for case-insensitive build directory)
-if test -d "python"
+if test -d "${srcdir}/python"
then
AC_MSG_RESULT(yes)
BUILDEXEEXT=.exe
@@ -2316,7 +2316,7 @@ do
done
AC_SUBST(SRCDIRS)
-SRCDIRS="Parser Grammar Objects Python Modules"
+SRCDIRS="Parser Grammar Objects Python Modules Mac Mac/Python"
AC_MSG_CHECKING(for build directories)
for dir in $SRCDIRS; do
if test ! -d $dir; then