summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMichael W. Hudson <mwh@python.net>2002-03-07 09:58:56 (GMT)
committerMichael W. Hudson <mwh@python.net>2002-03-07 09:58:56 (GMT)
commit0c46c0cc70613c34862513a2c8d679128146e90e (patch)
treedd1e60fe824a9904252f4489aaa5c69fc1597a77 /configure.in
parent02b28ec316114a646c7875a76edeb577c5c3581b (diff)
downloadcpython-0c46c0cc70613c34862513a2c8d679128146e90e.zip
cpython-0c46c0cc70613c34862513a2c8d679128146e90e.tar.gz
cpython-0c46c0cc70613c34862513a2c8d679128146e90e.tar.bz2
Apply Jack's patch attached to
[ 508779 ] Disable flat namespace on MacOS X I presume you wanted this on the trunk too, Jack? 2.2.1 candidate.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index d64174f..46560e9 100644
--- a/configure.in
+++ b/configure.in
@@ -793,8 +793,9 @@ then
# Link against the framework. All externals should be defined.
LDSHARED="$LDSHARED "'-framework $(PYTHONFRAMEWORK)'
else
- # No framework. Ignore undefined symbols, assuming they come from Python
- LDSHARED="$LDSHARED -flat_namespace -undefined suppress"
+ # No framework, use the Python app as bundle-loader
+ BLDSHARED="$LDSHARED "'-bundle_loader $(BUILDPYTHON)'
+ LDSHARED="$LDSHARED "'-bundle_loader $(BINDIR)/$(PYTHON)'
fi ;;
Linux*|GNU*) LDSHARED="gcc -shared";;
dgux*) LDSHARED="ld -G";;