summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2002-06-01 21:39:58 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2002-06-01 21:39:58 (GMT)
commit1931ca72b5769ee686776617e2d97d839cc7d2d6 (patch)
tree39a7c3a6cd51dabbadf80af1bf1f703f654d5c26 /configure.in
parent32200aeac697fcb3f2b4528127a2fbf0a22a8f17 (diff)
downloadcpython-1931ca72b5769ee686776617e2d97d839cc7d2d6.zip
cpython-1931ca72b5769ee686776617e2d97d839cc7d2d6.tar.gz
cpython-1931ca72b5769ee686776617e2d97d839cc7d2d6.tar.bz2
Use somewhat longer C++ program to detect whether linking requires the C++
compiler. Fixes #559429. 2.2 bugfix candidate.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 37c6f63..1003761 100644
--- a/configure.in
+++ b/configure.in
@@ -309,7 +309,7 @@ then
if test -z "$CXX"; then
LINKCC="\$(PURIFY) \$(CC)"
else
- echo 'int main(){return 0;}' > conftest.$ac_ext
+ echo 'void foo();int main(){foo();}void foo(){}' > conftest.$ac_ext
$CXX -c conftest.$ac_ext 2>&5
if $CC -o conftest$ac_exeext conftest.$ac_objext 2>&5 \
&& test -s conftest$ac_exeext && ./conftest$ac_exeext