summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2001-08-09 10:29:44 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2001-08-09 10:29:44 (GMT)
commit1d5ecb7cfa4656a275a316336a317d9194305698 (patch)
tree617e2d6fc3dd2966a813eadaa231af79c750f986 /configure.in
parentdf8dc365c53474189142308ecf99a3dcb1464c7e (diff)
downloadcpython-1d5ecb7cfa4656a275a316336a317d9194305698.zip
cpython-1d5ecb7cfa4656a275a316336a317d9194305698.tar.gz
cpython-1d5ecb7cfa4656a275a316336a317d9194305698.tar.bz2
Patch #433537: Cache ac_cv_bad_static_forward.
Also move up AC_AIX and AC_MINIX further up.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 13 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 2192d4c..55b57e8 100644
--- a/configure.in
+++ b/configure.in
@@ -171,6 +171,11 @@ then
fi
AC_PROG_CC
+
+# checks for UNIX variants that set C preprocessor variables
+AC_AIX
+AC_MINIX
+
AC_EXEEXT
AC_MSG_CHECKING(for --with-suffix)
AC_ARG_WITH(suffix, [ --with-suffix=.exe set executable suffix],[
@@ -349,9 +354,6 @@ if test "$ac_arch_flags"
then
OPT="$OPT $ac_arch_flags"
fi
-# checks for UNIX variants that set C preprocessor variables
-AC_AIX
-AC_MINIX
AC_MSG_CHECKING(whether $CC accepts -OPT:Olimit=0)
AC_CACHE_VAL(ac_cv_opt_olimit_ok,
@@ -1429,9 +1431,9 @@ x.sa_len = 0;],
AC_DEFINE(HAVE_SOCKADDR_SA_LEN),
AC_MSG_RESULT(no))
-bad_forward=no
AC_MSG_CHECKING(for bad static forward)
-AC_TRY_RUN([
+AC_CACHE_VAL(ac_cv_bad_static_forward,
+[AC_TRY_RUN([
struct s { int a; int b; };
static struct s foo;
int foobar() {
@@ -1442,9 +1444,12 @@ int foobar() {
static struct s foo = { 1, 2 };
main() {
exit(!((int)&foo == foobar()));
-}
-], , AC_DEFINE(BAD_STATIC_FORWARD) bad_forward=yes)
-AC_MSG_RESULT($bad_forward)
+}], ac_cv_bad_static_forward=no, ac_cv_bad_static_forward=yes)])
+AC_MSG_RESULT($ac_cv_bad_static_forward)
+if test "$ac_cv_bad_static_forward" = yes
+then
+ AC_DEFINE(BAD_STATIC_FORWARD)
+fi
va_list_is_array=no
AC_MSG_CHECKING(whether va_list is an array)