summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2002-03-08 13:43:01 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2002-03-08 13:43:01 (GMT)
commit4f8d05495d0ec8bea3354fc6627242bc785ec3db (patch)
tree69bdf9555427c543d98699af1e5cae2dfde04cad /configure.in
parent95f8495de81c43ddad62638368736ce33db4c88a (diff)
downloadcpython-4f8d05495d0ec8bea3354fc6627242bc785ec3db.zip
cpython-4f8d05495d0ec8bea3354fc6627242bc785ec3db.tar.gz
cpython-4f8d05495d0ec8bea3354fc6627242bc785ec3db.tar.bz2
When testing for availability of pthreads without special compiler options
or libraries also look for thread_detach. SGI has thread_create in libc but complete pthread support only in -lpthread. Fixes #522393. 2.2.1 candidate.Killed by signal 2.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 46560e9..da2ab8d 100644
--- a/configure.in
+++ b/configure.in
@@ -465,6 +465,7 @@ int main(){
pthread_t p;
if(pthread_create(&p,NULL,routine,NULL)!=0)
return 1;
+ (void)pthread_detach(p);
return 0;
}
],
@@ -497,6 +498,7 @@ int main(){
pthread_t p;
if(pthread_create(&p,NULL,routine,NULL)!=0)
return 1;
+ (void)pthread_detach(p);
return 0;
}
],