summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2001-09-10 15:34:42 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2001-09-10 15:34:42 (GMT)
commit5b718fc8a3ef93ced473b0285145fd0faecaab7e (patch)
tree7482cc30c37815e6f5c39a4f5b4815fcd7094188 /configure.in
parented5a7ca5eef65248b652b564781437c931aaffb3 (diff)
downloadcpython-5b718fc8a3ef93ced473b0285145fd0faecaab7e.zip
cpython-5b718fc8a3ef93ced473b0285145fd0faecaab7e.tar.gz
cpython-5b718fc8a3ef93ced473b0285145fd0faecaab7e.tar.bz2
Use $(CC) -G to link shared libraries on Solaris.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 7ade904..d667cab 100644
--- a/configure.in
+++ b/configure.in
@@ -650,7 +650,7 @@ then
fi
AC_MSG_RESULT($SO)
# LDSHARED is the ld *command* used to create shared library
-# -- "ld" on SunOS 4.x.x, "ld -G" on SunOS 5.x, "ld -shared" on IRIX 5
+# -- "ld" on SunOS 4.x.x, "cc -G" on SunOS 5.x, "ld -shared" on IRIX 5
# (Shared libraries in this instance are shared modules to be loaded into
# Python, as opposed to building Python itself as a shared library.)
AC_MSG_CHECKING(LDSHARED)
@@ -671,7 +671,7 @@ then
SunOS/5*)
if test "$GCC" = "yes"
then LDSHARED='$(CC) -shared'
- else LDSHARED="ld -G";
+ else LDSHARED="$(CC) -G";
fi ;;
hp*|HP*) LDSHARED="ld -b";;
OSF*) LDSHARED="ld -shared -expect_unresolved \"*\"";;