summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2010-04-18 19:07:43 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2010-04-18 19:07:43 (GMT)
commit666028b681485cfcc70d6b485ba9915f57207d34 (patch)
tree9a4934ee2c34c1abba127cea797a740857cfcc09 /configure.in
parentb27ee20b9c84bf30b59bf0c9b9da5e91c84932a1 (diff)
downloadcpython-666028b681485cfcc70d6b485ba9915f57207d34.zip
cpython-666028b681485cfcc70d6b485ba9915f57207d34.tar.gz
cpython-666028b681485cfcc70d6b485ba9915f57207d34.tar.bz2
Merged revisions 80187 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r80187 | ronald.oussoren | 2010-04-18 19:59:37 +0200 (Sun, 18 Apr 2010) | 6 lines Add the OSX universal binary related options to CFLAGS instead of BASECFLAGS. This fixes issue 8366 and is needed due to changes introduced in the fix for issue 1628484. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 20 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 0ec9dcf..2751b0e 100644
--- a/configure.in
+++ b/configure.in
@@ -908,6 +908,20 @@ yes)
Darwin*)
# -Wno-long-double, -no-cpp-precomp, and -mno-fused-madd
# used to be here, but non-Apple gcc doesn't accept them.
+ if test "${CC}" = gcc
+ then
+ AC_MSG_CHECKING(which compiler should be used)
+ case "${UNIVERSALSDK}" in
+ */MacOSX10.4u.sdk)
+ # Build using 10.4 SDK, force usage of gcc when the
+ # compiler is gcc, otherwise the user will get very
+ # confusing error messages when building on OSX 10.6
+ CC=gcc-4.0
+ CPP=cpp-4.0
+ ;;
+ esac
+ AC_MSG_RESULT($CC)
+ fi
if test "${enable_universalsdk}"; then
@@ -942,10 +956,12 @@ yes)
fi
- BASECFLAGS="${UNIVERSAL_ARCH_FLAGS} -isysroot ${UNIVERSALSDK} ${BASECFLAGS}"
- tgt=`sw_vers -productVersion | sed 's/\(10\.[[0-9]]*\).*/\1/'`
- if test "${UNIVERSALSDK}" != "/" -a "${tgt}" '>' '10.4' ; then
- CFLAGS="${UNIVERSAL_ARCH_FLAGS} -isysroot ${UNIVERSALSDK} ${CFLAGS}"
+ CFLAGS="${UNIVERSAL_ARCH_FLAGS} -isysroot ${UNIVERSALSDK} ${CFLAGS}"
+ if test "${UNIVERSALSDK}" != "/"
+ then
+ CFLAGS="-isysroot ${UNIVERSALSDK} ${CFLAGS}"
+ LDFLAGS="-isysroot ${UNIVERSALSDK} ${LDFLAGS}"
+ CPPFLAGSFLAGS="-isysroot ${UNIVERSALSDK} ${CPPFLAGS}"
fi
fi