summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2002-04-14 20:12:41 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2002-04-14 20:12:41 (GMT)
commit7b8c7546ebc1fc3688ef95768fa8b82f0f205490 (patch)
tree2e14b243347a9c38c82e2e774d4b201f23149916 /configure.in
parentdcd2dc2fffce8614c5d2b8d303a303a599b88a23 (diff)
downloadcpython-7b8c7546ebc1fc3688ef95768fa8b82f0f205490.zip
cpython-7b8c7546ebc1fc3688ef95768fa8b82f0f205490.tar.gz
cpython-7b8c7546ebc1fc3688ef95768fa8b82f0f205490.tar.bz2
Mass checkin of universal newline support.
Highlights: import and friends will understand any of \r, \n and \r\n as end of line. Python file input will do the same if you use mode 'U'. Everything can be disabled by configuring with --without-universal-newlines. See PEP278 for details.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8d1339a..d3211a0 100644
--- a/configure.in
+++ b/configure.in
@@ -1445,6 +1445,20 @@ then
fi
AC_MSG_RESULT($with_cycle_gc)
+# Check for universal newline support
+AC_MSG_CHECKING(for --with-universal-newline)
+AC_ARG_WITH(universal-newlines,
+[ --with(out)-universal-newlines disable/enable foreign newlines])
+
+if test -z "$with_universal_newlines"
+then with_universal_newlines="yes"
+fi
+if test "$with_universal_newlines" != "no"
+then
+ AC_DEFINE(WITH_UNIVERSAL_NEWLINES)
+fi
+AC_MSG_RESULT($with_universal_newlines)
+
# Check for Python-specific malloc support
AC_MSG_CHECKING(for --with-pymalloc)
AC_ARG_WITH(pymalloc,