summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2002-10-26 13:47:44 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2002-10-26 13:47:44 (GMT)
commit88afe666daf18cb93f78b2e7e025cb469ef7f551 (patch)
tree0ca2822ec068dc98d587c03c352432ec2308c2bb /configure.in
parentc9d07dfc8771569fbe649eb398a1efd45558c55e (diff)
downloadcpython-88afe666daf18cb93f78b2e7e025cb469ef7f551.zip
cpython-88afe666daf18cb93f78b2e7e025cb469ef7f551.tar.gz
cpython-88afe666daf18cb93f78b2e7e025cb469ef7f551.tar.bz2
Patch #623771: Properly use autoconf 2.5x macros.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index a3b726c..a7f6ac2 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,12 @@
dnl Process this file with autoconf 2.0 or later to make a configure script.
+
+# Set VERSION so we only need to edit in one place (i.e., here)
+m4_define(PYTHON_VERSION, 2.3)
+
AC_REVISION($Revision$)
AC_PREREQ(2.53)
-AC_INIT(Include/object.h)
+AC_INIT(python, PYTHON_VERSION)
+AC_CONFIG_SRCDIR([Include/object.h])
AC_CONFIG_HEADER(pyconfig.h)
# This is for stuff that absolutely must end up in pyconfig.h.
@@ -13,9 +18,8 @@ AH_BOTTOM([
#endif
])
-# Set VERSION so we only need to edit in one place (i.e., here)
AC_SUBST(VERSION)
-VERSION=2.3
+VERSION=PYTHON_VERSION
AC_SUBST(SOVERSION)
SOVERSION=1.0
@@ -2397,7 +2401,8 @@ done
AC_MSG_RESULT(done)
# generate output files
-AC_OUTPUT(Makefile.pre Modules/Setup.config)
+AC_CONFIG_FILES(Makefile.pre Modules/Setup.config)
+AC_OUTPUT
echo "creating Setup"
if test ! -f Modules/Setup