summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2000-09-19 00:46:46 (GMT)
committerGuido van Rossum <guido@python.org>2000-09-19 00:46:46 (GMT)
commit9e8181b809c0dc40f86d66ce7e51db83aaeccd20 (patch)
tree905b001aa2fe3c15cc51668151974dfb05dd51d4 /configure.in
parent0344424793599e005b7071dd0338f508ac0d5168 (diff)
downloadcpython-9e8181b809c0dc40f86d66ce7e51db83aaeccd20.zip
cpython-9e8181b809c0dc40f86d66ce7e51db83aaeccd20.tar.gz
cpython-9e8181b809c0dc40f86d66ce7e51db83aaeccd20.tar.bz2
Make better use of GNU Pth -- patch by Andy Dustman.
I can't test this, so I'm just checking it in with blind faith in Andy. I've tested that it doesn't broeak a non-Pth build on Linux. Changes include: - There's a --with-pth configure option. - Instead of _GNU_PTH, we test for HAVE_PTH. - Better signal handling. - (The config.h.in file is regenerated in a slightly different order.)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index d36f312..4dd8e72 100644
--- a/configure.in
+++ b/configure.in
@@ -745,6 +745,15 @@ else
AC_CHECK_HEADER(mach/cthreads.h, [AC_DEFINE(WITH_THREAD)
AC_DEFINE(C_THREADS)
LIBOBJS="$LIBOBJS thread.o"],[
+ AC_MSG_CHECKING(for --with-pth)
+ AC_ARG_WITH(pth,
+ [ --with-pth use GNU pth threading libraries], [
+ AC_MSG_RESULT($withval)
+ AC_DEFINE(WITH_THREAD)
+ AC_DEFINE(HAVE_PTH)
+ LIBS="-lpth $LIBS"
+ LIBOBJS="$LIBOBJS thread.o"],[
+ AC_MSG_RESULT(no)
AC_CHECK_LIB(pthread, pthread_create, [AC_DEFINE(WITH_THREAD)
AC_DEFINE(_POSIX_THREADS)
LIBS="-lpthread $LIBS"
@@ -767,10 +776,6 @@ else
AC_DEFINE(_POSIX_THREADS)
LIBS="$LIBS -lthread"
LIBOBJS="$LIBOBJS thread.o"], [
- AC_CHECK_LIB(pth, pth_init, [AC_DEFINE(WITH_THREAD)
- AC_DEFINE(_GNU_PTH)
- LIBS="-lpth $LIBS"
- LIBOBJS="$LIBOBJS thread.o"],[
AC_CHECK_LIB(cma, pthread_create, [AC_DEFINE(WITH_THREAD)
AC_DEFINE(_POSIX_THREADS)
LIBS="$LIBS -lcma"