summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2002-06-09 13:33:54 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2002-06-09 13:33:54 (GMT)
commita3fb4f78164e55ddecfd875b9b33791850213dfd (patch)
tree1dfd36be033b76aa1ce46a42e50ea570e130c68c /configure.in
parentec5d6b908c25d45ffcf5b5ad60cdb51b38b6a769 (diff)
downloadcpython-a3fb4f78164e55ddecfd875b9b33791850213dfd.zip
cpython-a3fb4f78164e55ddecfd875b9b33791850213dfd.tar.gz
cpython-a3fb4f78164e55ddecfd875b9b33791850213dfd.tar.bz2
Patch #505375: Make doc strings optional.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 609ffcb..55f1f55 100644
--- a/configure.in
+++ b/configure.in
@@ -1455,6 +1455,21 @@ then
fi
AC_MSG_RESULT($with_universal_newlines)
+# Check for --with-doc-strings
+AC_MSG_CHECKING(for --with-doc-strings)
+AC_ARG_WITH(doc-strings,
+[ --with(out)-doc-strings disable/enable documentation strings])
+
+if test -z "$with_doc_strings"
+then with_doc_strings="yes"
+fi
+if test "$with_doc_strings" != "no"
+then
+ AC_DEFINE(WITH_DOC_STRINGS, 1,
+ [Define if you want documentation strings in extension modules])
+fi
+AC_MSG_RESULT($with_doc_strings)
+
# Check for Python-specific malloc support
AC_MSG_CHECKING(for --with-pymalloc)
AC_ARG_WITH(pymalloc,