summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2001-11-14 10:59:57 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2001-11-14 10:59:57 (GMT)
commit418c3b1e26770dd3920ed750f53f586b374e61bb (patch)
tree78d56b163509fa14aa43fc01b1c8934f46e6d6aa /configure.in
parent00cafa0f76aa5860386d6fecabc61132cc7711a4 (diff)
downloadcpython-418c3b1e26770dd3920ed750f53f586b374e61bb.zip
cpython-418c3b1e26770dd3920ed750f53f586b374e61bb.tar.gz
cpython-418c3b1e26770dd3920ed750f53f586b374e61bb.tar.bz2
OSX tests used specific version numbers to test for new features and
used the default Darwin/* for the old code. Reversed those tests so that compatibility code is in a switch leg with a specific version and newer systems take the default leg. This should allow Python to build on OSX 10.1.1 (which jumps from Darwin/1.4 to Darwin/5.1 due to a new numbering scheme).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 34a0806..68d352e 100644
--- a/configure.in
+++ b/configure.in
@@ -670,16 +670,16 @@ AC_MSG_RESULT($enable_toolbox_glue)
AC_SUBST(LIBTOOL_CRUFT)
case $ac_sys_system/$ac_sys_release in
- Darwin/1.4*)
+ Darwin/1.3*)
ns_undef_sym='_environ'
- LIBTOOL_CRUFT="-lcc_dynamic -arch_only ppc -flat_namespace -U $ns_undef_sym"
- LIBTOOL_CRUFT="$LIBTOOL_CRUFT $extra_frameworks"
+ LIBTOOL_CRUFT="-lcc_dynamic -arch_only ppc -U $ns_undef_sym"
+ LIBTOOL_CRUFT="$LIBTOOL_CRUFT $extra_frameworks"
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKDIR)/Versions/$(VERSION)/Python'
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
Darwin/*)
ns_undef_sym='_environ'
- LIBTOOL_CRUFT="-lcc_dynamic -arch_only ppc -U $ns_undef_sym"
- LIBTOOL_CRUFT="$LIBTOOL_CRUFT $extra_frameworks"
+ LIBTOOL_CRUFT="-lcc_dynamic -arch_only ppc -flat_namespace -U $ns_undef_sym"
+ LIBTOOL_CRUFT="$LIBTOOL_CRUFT $extra_frameworks"
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKDIR)/Versions/$(VERSION)/Python'
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
esac
@@ -694,8 +694,8 @@ then
# in the build location.
case $ac_sys_system/$ac_sys_release in
- Darwin/1.4*)LDFLAGS="$LDFLAGS -Wl,-F. -Wl,-flat_namespace,-U,$ns_undef_sym";;
- Darwin/*)LDFLAGS="$LDFLAGS -Wl,-F. -Wl,-U,$ns_undef_sym";;
+ Darwin/1.3*)LDFLAGS="$LDFLAGS -Wl,-F. -Wl,-U,$ns_undef_sym";;
+ Darwin/*)LDFLAGS="$LDFLAGS -Wl,-F. -Wl,-flat_namespace,-U,$ns_undef_sym";;
esac
AC_DEFINE(WITH_NEXT_FRAMEWORK)
AC_MSG_RESULT(yes)
@@ -759,14 +759,14 @@ then
hp*|HP*) LDSHARED="ld -b";;
OSF*) LDSHARED="ld -shared -expect_unresolved \"*\"";;
DYNIX/ptx*) LDSHARED="ld -G";;
- Darwin/1.4*)
+ Darwin/1.3*)
LDSHARED='$(CC) $(LDFLAGS) -bundle'
if test "$enable_framework" ; then
# Link against the framework. All externals should be defined.
LDSHARED="$LDSHARED "'-framework $(PYTHONFRAMEWORK)'
else
# No framework. Ignore undefined symbols, assuming they come from Python
- LDSHARED="$LDSHARED -flat_namespace -undefined suppress"
+ LDSHARED="$LDSHARED -undefined suppress"
fi ;;
Darwin/*)
LDSHARED='$(CC) $(LDFLAGS) -bundle'
@@ -775,7 +775,7 @@ then
LDSHARED="$LDSHARED "'-framework $(PYTHONFRAMEWORK)'
else
# No framework. Ignore undefined symbols, assuming they come from Python
- LDSHARED="$LDSHARED -undefined suppress"
+ LDSHARED="$LDSHARED -flat_namespace -undefined suppress"
fi ;;
Linux*) LDSHARED="gcc -shared";;
dgux*) LDSHARED="ld -G";;