summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2005-11-26 11:38:37 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2005-11-26 11:38:37 (GMT)
commit66b392b053c87bc1700992e3999a91f95718861a (patch)
treee534830288665883b4a56122360a065b37b25bf7 /configure.in
parent7b08ff2003d2747ac5c1df16f1a308b171b718b0 (diff)
downloadcpython-66b392b053c87bc1700992e3999a91f95718861a.zip
cpython-66b392b053c87bc1700992e3999a91f95718861a.tar.gz
cpython-66b392b053c87bc1700992e3999a91f95718861a.tar.bz2
Patch #1227966: Do not defined _XOPEN_SOURCE_EXTENDED on Solaris 10.
Also set _XOPEN_SOURCE to 500.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 5ad6adb..1a8a887 100644
--- a/configure.in
+++ b/configure.in
@@ -183,8 +183,10 @@ if test $define_xopen_source = yes
then
# On Solaris w/ g++ it appears that _XOPEN_SOURCE has to be
# defined precisely as g++ defines it
+ # Furthermore, on Solaris 10, XPG6 requires the use of a C99
+ # compiler
case $ac_sys_system/$ac_sys_release in
- SunOS/5.8|SunOS/5.9)
+ SunOS/5.8|SunOS/5.9|SunOS/5.10)
AC_DEFINE(_XOPEN_SOURCE, 500,
Define to the level of X/Open that your system supports)
;;
@@ -198,8 +200,16 @@ then
# definition of _XOPEN_SOURCE_EXTENDED and _POSIX_C_SOURCE, or else
# several APIs are not declared. Since this is also needed in some
# cases for HP-UX, we define it globally.
-
- AC_DEFINE(_XOPEN_SOURCE_EXTENDED, 1, Define to activate Unix95-and-earlier features)
+ # except for Solaris 10, where it must not be defined,
+ # as it implies XPG4.2
+ case $ac_sys_system/$ac_sys_release in
+ SunOS/5.10)
+ ;;
+ *)
+ AC_DEFINE(_XOPEN_SOURCE_EXTENDED, 1,
+ Define to activate Unix95-and-earlier features)
+ ;;
+ esac
AC_DEFINE(_POSIX_C_SOURCE, 200112L, Define to activate features from IEEE Stds 1003.1-2001)