summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSkip Montanaro <skip@pobox.com>2004-01-17 00:29:32 (GMT)
committerSkip Montanaro <skip@pobox.com>2004-01-17 00:29:32 (GMT)
commit4d474becd8cbe76e8a72e4b834be285a156a3787 (patch)
treea4cdee847397dcb70f20e8455522d089edb9651b /configure.in
parentb9820a3b77c35e3e584c468d01c30d2ef78a5164 (diff)
downloadcpython-4d474becd8cbe76e8a72e4b834be285a156a3787.zip
cpython-4d474becd8cbe76e8a72e4b834be285a156a3787.tar.gz
cpython-4d474becd8cbe76e8a72e4b834be285a156a3787.tar.bz2
remove DGUX support.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 1 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 2628806..602b864 100644
--- a/configure.in
+++ b/configure.in
@@ -332,7 +332,7 @@ AC_AIX
# Check for unsupported systems
case $ac_sys_system/$ac_sys_release in
-SunOS/4*|DYNIX/*|dgux*/*|IRIX/4*|Linux*/1*)
+SunOS/4*|DYNIX/*|IRIX/4*|Linux*/1*)
echo This system \($ac_sys_system/$ac_sys_release\) is no longer supported.
echo See README for details.
exit 1;;
@@ -457,8 +457,6 @@ then
exp_extra="."
fi
LINKCC="\$(srcdir)/Modules/makexp_aix Modules/python.exp $exp_extra \$(LIBRARY); $LINKCC";;
- dgux*)
- LINKCC="LD_RUN_PATH=$libdir $LINKCC";;
Monterey64*)
LINKCC="$LINKCC -L/usr/lib/ia64l64";;
esac
@@ -537,13 +535,6 @@ if test $enable_shared = "yes"; then
RUNSHARED=DLL_PATH=`pwd`:${DLL_PATH:-/atheos/sys/libs:/atheos/autolnk/lib}
;;
esac
- # DG/UX requires some fancy ld contortions to produce a .so from an .a
- case $MACHDEP in
- dguxR4)
- LDLIBRARY='libpython$(VERSION).so'
- BASECFLAGS="$BASECFLAGS -pic"
- ;;
- esac
else # shared is disabled
case $ac_sys_system in
CYGWIN*)
@@ -1278,7 +1269,6 @@ then
LDSHARED="$LDSHARED "'-bundle_loader $(BINDIR)/python$(VERSION)$(EXE)'
fi ;;
Linux*|GNU*) LDSHARED='$(CC) -shared';;
- dgux*) LDSHARED="ld -G";;
BSD/OS*/4*) LDSHARED="gcc -shared";;
OpenBSD*|FreeBSD*)
if [[ "`$CC -dM -E - </dev/null | grep __ELF__`" != "" ]]