summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNeil Schemenauer <nascheme@enme.ucalgary.ca>2001-02-19 18:17:33 (GMT)
committerNeil Schemenauer <nascheme@enme.ucalgary.ca>2001-02-19 18:17:33 (GMT)
commit95052725115953bb19bdef16b6410c8393eaa19c (patch)
treedf172dddae256b7e0985945aa1b8d98330ace1e5 /configure.in
parent653809c1228031b469c4a53afdf6248033c27e3e (diff)
downloadcpython-95052725115953bb19bdef16b6410c8393eaa19c.zip
cpython-95052725115953bb19bdef16b6410c8393eaa19c.tar.gz
cpython-95052725115953bb19bdef16b6410c8393eaa19c.tar.bz2
Revert SF patch #103655. Martin Löwis says:
-shared does the following things: - invoke the linker with -G -dy -z text (the latter only if -mimpure-text was not given) - drop crt1.o from the list of objects being linked - drop -lc from the list of libraries being linked OTOH, -G is just passed through to the linker. The things that -shared does are necessary: crt1.o defines _start, and requires main, so it should not be present in a shared library. Likewise, -z text should be used to detect position-dependent code at compile time.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 909b914..1457a03 100644
--- a/configure.in
+++ b/configure.in
@@ -544,7 +544,7 @@ then
SunOS/4*) LDSHARED="ld";;
SunOS/5*)
if test "$GCC" = "yes"
- then LDSHARED='$(CC) -G'
+ then LDSHARED='$(CC) -shared'
else LDSHARED="ld -G";
fi ;;
hp*|HP*) LDSHARED="ld -b";;