summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2002-05-15 18:24:06 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2002-05-15 18:24:06 (GMT)
commit1e1fcef756dbec60c9062462b46777ffc2a0594e (patch)
tree295afbac597dab65c10fce679260c9347128031f /configure.in
parentb07fa39edfdae1f7777bb39eceb133f67e8eee62 (diff)
downloadcpython-1e1fcef756dbec60c9062462b46777ffc2a0594e.zip
cpython-1e1fcef756dbec60c9062462b46777ffc2a0594e.tar.gz
cpython-1e1fcef756dbec60c9062462b46777ffc2a0594e.tar.bz2
Back out #555929
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c90f60c..dcae3d8 100644
--- a/configure.in
+++ b/configure.in
@@ -7,6 +7,16 @@ AC_CONFIG_HEADER(pyconfig.h)
# This is for stuff that absolutely must end up in pyconfig.h.
# Please use pyport.h instead, if possible.
AH_BOTTOM([
+#ifdef __CYGWIN__
+#ifdef USE_DL_IMPORT
+#define DL_IMPORT(RTYPE) __declspec(dllimport) RTYPE
+#define DL_EXPORT(RTYPE) __declspec(dllexport) RTYPE
+#else
+#define DL_IMPORT(RTYPE) __declspec(dllexport) RTYPE
+#define DL_EXPORT(RTYPE) __declspec(dllexport) RTYPE
+#endif
+#endif
+
/* Define the macros needed if on a UnixWare 7.x system. */
#if defined(__USLC__) && defined(__SCO_VERSION__)
#define STRICT_SYSV_CURSES /* Don't use ncurses extensions */