summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFred Drake <fdrake@acm.org>2000-10-26 17:09:35 (GMT)
committerFred Drake <fdrake@acm.org>2000-10-26 17:09:35 (GMT)
commit036144d26d8c5fc1b7429cc3f352e1ea96e16aae (patch)
tree9a84599e75de19fa365ea5491bba53aed79ad27e /configure.in
parentcf3bc8c5a5ecebb2aa4facc5eecfe8f3acec8b9b (diff)
downloadcpython-036144d26d8c5fc1b7429cc3f352e1ea96e16aae.zip
cpython-036144d26d8c5fc1b7429cc3f352e1ea96e16aae.tar.gz
cpython-036144d26d8c5fc1b7429cc3f352e1ea96e16aae.tar.bz2
Test for and create Modules/Setup in the configure script if it does not
already exist.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7445e6d..6e9ab34 100644
--- a/configure.in
+++ b/configure.in
@@ -1294,6 +1294,14 @@ cat >> confdefs.h <<\EOF
EOF
AC_CHECK_TYPE(socklen_t, int)
+AC_MSG_CHECKING(for Modules/Setup)
+if test ! -f Modules/Setup ; then
+ cp "$srcdir/Modules/Setup.dist" Modules/Setup
+ AC_MSG_RESULT(creating)
+else
+ AC_MSG_RESULT(already exists)
+fi
+
# generate output files
AC_OUTPUT(Makefile \
Objects/Makefile \