summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2006-10-02 15:24:01 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2006-10-02 15:24:01 (GMT)
commit33bb6102ec7f4734b10c54b13eb14dd4352d7bae (patch)
treefcf3bfd779e766b431c5e50a924ea976a8d98474 /configure.in
parentda70fd15992ec2833f02ac4e5a31d4675f3ee5f8 (diff)
downloadcpython-33bb6102ec7f4734b10c54b13eb14dd4352d7bae.zip
cpython-33bb6102ec7f4734b10c54b13eb14dd4352d7bae.tar.gz
cpython-33bb6102ec7f4734b10c54b13eb14dd4352d7bae.tar.bz2
Guard uintptr_t test with HAVE_STDINT_H, test for
stdint.h.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index c5d69f9..ba3f445 100644
--- a/configure.in
+++ b/configure.in
@@ -1068,8 +1068,8 @@ dnl AC_MSG_RESULT($cpp_type)
AC_HEADER_STDC
AC_CHECK_HEADERS(asm/types.h conio.h curses.h direct.h dlfcn.h errno.h \
fcntl.h grp.h \
-shadow.h io.h langinfo.h libintl.h ncurses.h poll.h process.h pthread.h \
-signal.h stropts.h termios.h thread.h \
+io.h langinfo.h libintl.h ncurses.h poll.h process.h pthread.h \
+shadow.h signal.h stdint.h stropts.h termios.h thread.h \
unistd.h utime.h \
sys/audioio.h sys/bsdtty.h sys/file.h sys/loadavg.h sys/lock.h sys/mkdev.h \
sys/modem.h \
@@ -1199,7 +1199,9 @@ fi
AC_CHECK_TYPES(uintptr_t,
[AC_CHECK_SIZEOF(uintptr_t, 4)],
- [], [#include <stdint.h>])
+ [], [#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+ #endif])
# Hmph. AC_CHECK_SIZEOF() doesn't include <sys/types.h>.