summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorWalter Dörwald <walter@livinglogic.de>2006-06-19 08:07:50 (GMT)
committerWalter Dörwald <walter@livinglogic.de>2006-06-19 08:07:50 (GMT)
commit4994d9546c723c01c2f4b34a401c544c859d3404 (patch)
tree92805448d61e0ad9ae61452c93e01522d40a9acc /configure.in
parent43bc3788c0333b5d6230a5a28885b2fa70b42a86 (diff)
downloadcpython-4994d9546c723c01c2f4b34a401c544c859d3404.zip
cpython-4994d9546c723c01c2f4b34a401c544c859d3404.tar.gz
cpython-4994d9546c723c01c2f4b34a401c544c859d3404.tar.bz2
Patch #1506645: add Python wrappers for the curses functions
is_term_resized, resize_term and resizeterm. This uses three separate configure checks (one for each function).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1b7b57e..2e9ea10 100644
--- a/configure.in
+++ b/configure.in
@@ -3295,6 +3295,27 @@ then
[Define if WINDOW in curses.h offers a field _flags.])
fi
+AC_MSG_CHECKING(for is_term_resized)
+AC_TRY_COMPILE([#include <curses.h>], void *x=is_term_resized,
+ AC_DEFINE(HAVE_CURSES_IS_TERM_RESIZED, 1, Define if you have the 'is_term_resized' function.)
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+
+AC_MSG_CHECKING(for resizeterm)
+AC_TRY_COMPILE([#include <curses.h>], void *x=resizeterm,
+ AC_DEFINE(HAVE_CURSES_RESIZETERM, 1, Define if you have the 'resizeterm' function.)
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+
+AC_MSG_CHECKING(for resize_term)
+AC_TRY_COMPILE([#include <curses.h>], void *x=resize_term,
+ AC_DEFINE(HAVE_CURSES_RESIZE_TERM, 1, Define if you have the 'resize_term' function.)
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+
AC_MSG_CHECKING(for /dev/ptmx)
if test -e /dev/ptmx