summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2006-02-10 20:49:30 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2006-02-10 20:49:30 (GMT)
commit82bca63c2be3394b0ad1d2e2fd3c412464e60ebf (patch)
tree76a1dda86993a4c4201a75a81894fde1db995e15 /configure.in
parent03904bf20b1bd161ee2cfdeb87797ed1f877a02b (diff)
downloadcpython-82bca63c2be3394b0ad1d2e2fd3c412464e60ebf.zip
cpython-82bca63c2be3394b0ad1d2e2fd3c412464e60ebf.tar.gz
cpython-82bca63c2be3394b0ad1d2e2fd3c412464e60ebf.tar.bz2
Avoid linking python with readline.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1950072..3892528 100644
--- a/configure.in
+++ b/configure.in
@@ -2898,6 +2898,8 @@ then
fi
# check where readline lives
+# save the value of LIBS so we don't actually link Python with readline
+LIBS_no_readline=$LIBS
AC_CHECK_LIB(readline, readline)
if test "$ac_cv_have_readline_readline" = no
then
@@ -2941,6 +2943,9 @@ then
[Define if you can turn off readline's signal handling.]), )
fi
+# End of readline checks: restore LIBS
+LIBS=$LIBS_no_readline
+
AC_MSG_CHECKING(for broken nice())
AC_CACHE_VAL(ac_cv_broken_nice, [
AC_TRY_RUN([