summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2002-11-11 13:37:28 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2002-11-11 13:37:28 (GMT)
commitbddf5a57ca94b93d251492b5adc50814e891e7f2 (patch)
treefb0b509d9eb4c44bd96ec4895bb7539fc54f188b /configure.in
parente981a4eb3607f8b18acc1c715a6789f7aa7ac07c (diff)
downloadcpython-bddf5a57ca94b93d251492b5adc50814e891e7f2.zip
cpython-bddf5a57ca94b93d251492b5adc50814e891e7f2.tar.gz
cpython-bddf5a57ca94b93d251492b5adc50814e891e7f2.tar.bz2
Protect pyconfig.h from multiple inclusions.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 79ace17..07f452d 100644
--- a/configure.in
+++ b/configure.in
@@ -11,11 +11,17 @@ AC_CONFIG_HEADER(pyconfig.h)
# This is for stuff that absolutely must end up in pyconfig.h.
# Please use pyport.h instead, if possible.
+AH_TOP([
+#ifndef Py_PYCONFIG_H
+#define Py_PYCONFIG_H
+])
AH_BOTTOM([
/* Define the macros needed if on a UnixWare 7.x system. */
#if defined(__USLC__) && defined(__SCO_VERSION__)
#define STRICT_SYSV_CURSES /* Don't use ncurses extensions */
#endif
+
+#endif /*Py_PYCONFIG_H*/
])
AC_SUBST(VERSION)