summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1996-08-30 15:18:00 (GMT)
committerGuido van Rossum <guido@python.org>1996-08-30 15:18:00 (GMT)
commitf2f7eb34c8462a3b8d53d665708cdd294001a136 (patch)
treef0c01ce554344e65cd53d346949af7efae935dd8 /configure.in
parent5ab007b098011714d80441397c9f34d747539a2d (diff)
downloadcpython-f2f7eb34c8462a3b8d53d665708cdd294001a136.zip
cpython-f2f7eb34c8462a3b8d53d665708cdd294001a136.tar.gz
cpython-f2f7eb34c8462a3b8d53d665708cdd294001a136.tar.bz2
Added checks for strdup and changed checks for hypot.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index a5e34d7..bc82b06 100644
--- a/configure.in
+++ b/configure.in
@@ -223,7 +223,7 @@ AC_CHECK_LIB(sun, getpwnam) # NIS (== YP) interface for IRIX 4
# broken. I see no elegant solution (probably CHECK_LIB should be
# fixed to only add the library if the given entry point is not
# satisfied without it).
-if test "`uname -s`" != IRIX
+if test "$ac_sys_system" != IRIX
then
AC_CHECK_LIB(nsl, t_open, [LIBS="-lnsl $LIBS"]) # SVR4
AC_CHECK_LIB(inet, gethostbyname, [LIBS="-linet $LIBS"], [], -lnsl) # Sequent
@@ -321,7 +321,7 @@ AC_CHECK_FUNCS(chown clock dlopen flock ftime ftruncate \
select setgid setuid setsid setpgid setpgrp setvbuf \
sigaction siginterrupt sigrelse strftime symlink \
tcgetpgrp tcsetpgrp times truncate uname waitpid)
-AC_REPLACE_FUNCS(dup2 getcwd strerror memmove)
+AC_REPLACE_FUNCS(dup2 getcwd strdup strerror memmove)
AC_CHECK_FUNC(getpgrp, AC_TRY_COMPILE([#include <unistd.h>], [getpgrp(0);], AC_DEFINE(GETPGRP_HAVE_ARG)))
AC_CHECK_FUNC(setpgrp, AC_TRY_COMPILE([#include <unistd.h>], [setpgrp(0,0);], AC_DEFINE(SETPGRP_HAVE_ARG)))
AC_CHECK_FUNC(gettimeofday, AC_TRY_COMPILE([#include <sys/time.h>], [gettimeofday((struct timeval*)0,(struct timezone*)0);], ,AC_DEFINE(GETTIMEOFDAY_NO_TZ)))
@@ -445,6 +445,7 @@ fi])
LIBS_SAVE=$LIBS
LIBS="$LIBS $LIBM"
AC_CHECK_FUNCS(hypot)
+AC_REPLACE_FUNCS(hypot)
LIBS=$LIBS_SAVE
# check for getopt