summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1997-08-06 23:42:07 (GMT)
committerGuido van Rossum <guido@python.org>1997-08-06 23:42:07 (GMT)
commitfb84255e6756adcb4c38e23d63c0f3c017012789 (patch)
tree9d3c1117729bb91258f2ead299a2a71ec9b35b18 /configure.in
parentb06df27843611d9b1a9988da7aacf01073a1fbc4 (diff)
downloadcpython-fb84255e6756adcb4c38e23d63c0f3c017012789.zip
cpython-fb84255e6756adcb4c38e23d63c0f3c017012789.tar.gz
cpython-fb84255e6756adcb4c38e23d63c0f3c017012789.tar.bz2
New version of Vladimir Marangozov's AIX hacks -- simpler etc.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ba17455..21ac890 100644
--- a/configure.in
+++ b/configure.in
@@ -81,6 +81,21 @@ then
fi
AC_PROG_CC
+
+# LINKCC is the command that links the python executable -- default is $(CC).
+# This is altered for AIX in order to build the export list before linking.
+AC_SUBST(LINKCC)
+AC_MSG_CHECKING(LINKCC)
+if test -z "$LINKCC"
+then
+ case $ac_sys_system in
+ AIX*)
+ LINKCC="makexp_aix python.exp \"\" \$(MYLIBS) \$(ADDOBJS); \$(CC)";;
+ *) LINKCC="\$(CC)";;
+ esac
+fi
+AC_MSG_RESULT($LINKCC)
+
AC_PROG_RANLIB
AC_SUBST(AR)
AC_CHECK_PROGS(AR, ar aal, ar)