summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2001-10-20 14:21:45 (GMT)
committerGuido van Rossum <guido@python.org>2001-10-20 14:21:45 (GMT)
commit67b2659046b624dcd84c09a3912caf33eeb53733 (patch)
treece37650ed5aa90dbe941529378288fe54a16c4fb /configure.in
parent0aa811c527372fbee0e20192bba3cf343a744e08 (diff)
downloadcpython-67b2659046b624dcd84c09a3912caf33eeb53733.zip
cpython-67b2659046b624dcd84c09a3912caf33eeb53733.tar.gz
cpython-67b2659046b624dcd84c09a3912caf33eeb53733.tar.bz2
Patch from SF bug #473150: configure weaknesses on HP-UX (Michael Piotrowski)
1. configure doesn't handle HP-UX release numbers (e.g., B.11.00), resulting in MACHDEP = "hpuxB". 2. After checking for wchar.h, configure doesn't include it when checking the size of wchar_t. (Python 2.2b1 on HP-UX 11.00)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 96ba400..9c72c31 100644
--- a/configure.in
+++ b/configure.in
@@ -63,7 +63,7 @@ then
ac_md_system=`echo $ac_sys_system |
tr -d '[/ ]' | tr '[[A-Z]]' '[[a-z]]'`
ac_md_release=`echo $ac_sys_release |
- tr -d '[/ ]' | sed 's/\..*//'`
+ tr -d '[/ ]' | sed 's/^[[A-Z]]\.//' | sed 's/\..*//'`
MACHDEP="$ac_md_system$ac_md_release"
case $MACHDEP in
@@ -1834,7 +1834,7 @@ wchar_h="no"
# determine wchar_t size
if test "$wchar_h" = yes
then
- AC_CHECK_SIZEOF(wchar_t, 4)
+ AC_CHECK_SIZEOF(wchar_t, 4, [#include <wchar.h>])
fi
AC_MSG_CHECKING(what type to use for unicode)