summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFred Drake <fdrake@acm.org>2001-03-06 05:52:16 (GMT)
committerFred Drake <fdrake@acm.org>2001-03-06 05:52:16 (GMT)
commita1a84e7d4f7b493bb6fa5415ce55d3f722221470 (patch)
treecc41a82403ef79d97d108b1d750489a415604aa4 /configure.in
parentb25ec91a94e006dc7b4776e6b3b781b0dc818336 (diff)
downloadcpython-a1a84e7d4f7b493bb6fa5415ce55d3f722221470.zip
cpython-a1a84e7d4f7b493bb6fa5415ce55d3f722221470.tar.gz
cpython-a1a84e7d4f7b493bb6fa5415ce55d3f722221470.tar.bz2
Move all knowledge that $(MAINOBJ) is built in the Modules/ directory
into Makefile.pre.in; the configure script will only determine the basename of the file. This fixes installation of a Python built using C++, reported by Greg Wilson.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index bb439c7..92a5b46 100644
--- a/configure.in
+++ b/configure.in
@@ -128,7 +128,7 @@ AC_MSG_RESULT($without_gcc)
AC_SUBST(CXX)
AC_SUBST(MAINOBJ)
-MAINOBJ=Modules/python.o
+MAINOBJ=python.o
AC_MSG_CHECKING(for --with-cxx=<compiler>)
AC_ARG_WITH(cxx, [ --with-cxx=<compiler> enable C++ support],[
check_cxx=no
@@ -136,7 +136,7 @@ AC_ARG_WITH(cxx, [ --with-cxx=<compiler> enable C++ support],[
no) CXX=
with_cxx=no;;
*) CXX=$withval
- MAINOBJ=Modules/ccpython.o
+ MAINOBJ=ccpython.o
with_cxx=$withval;;
esac], [
with_cxx=no