summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFred Drake <fdrake@acm.org>2000-06-29 20:44:47 (GMT)
committerFred Drake <fdrake@acm.org>2000-06-29 20:44:47 (GMT)
commita3f6e91307fa45c5eb88c3dd7c573ba5ad7df199 (patch)
treef8130efa42c7c36432e6e1c6f791657143823a97 /configure.in
parentd04038d9d2f7950d533a33d6c01b7911f90c0c2a (diff)
downloadcpython-a3f6e91307fa45c5eb88c3dd7c573ba5ad7df199.zip
cpython-a3f6e91307fa45c5eb88c3dd7c573ba5ad7df199.tar.gz
cpython-a3f6e91307fa45c5eb88c3dd7c573ba5ad7df199.tar.bz2
This patch extends PC/config.h and configure.in as appropriate for
64-bit readiness (the config values are needed for patches that I will be submitting later today. The changes are as follows: - add SIZEOF_OFF_T #define's to PC/config.h (it was already in configure.in) - add SIZEOF_TIME_T #define to PC/config.h and configure Needed for some buffer overflow checking because sizeof(time_t) is different on Win64. - add SIZEOF_FPOS_T #define Needed for the Win64 large file support implementation. - add SIZEOF_HKEY in PC/config.h only Needed for proper Win32 vs. Win64 handling in PC/winreg.c - #define HAVE_LARGEFILE_SUPPORT for Win64 - typedef long intptr_t; for all Windows except Win64 (which defines it itself) This is a new ANSI (I think) type that is useful (and used by me) for proper handling in msvcrtmodule.c and posixmodule.c - indent the nested #ifdef's and #defines in PC/config.h This is *so* much more readable. There cannot be a compiler compatibilty issue here can there? Perl uses indented #defines and it compiles with everything.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fd5f368..5790801 100644
--- a/configure.in
+++ b/configure.in
@@ -389,6 +389,7 @@ AC_CHECK_SIZEOF(char)
AC_CHECK_SIZEOF(short)
AC_CHECK_SIZEOF(float)
AC_CHECK_SIZEOF(double)
+AC_CHECK_SIZEOF(fpos_t)
AC_MSG_CHECKING(for long long support)
have_long_long=no
@@ -424,6 +425,22 @@ else
AC_MSG_RESULT(no)
fi
+# AC_CHECK_SIZEOF() doesn't include <time.h>.
+AC_MSG_CHECKING(size of time_t)
+AC_CACHE_VAL(ac_cv_sizeof_time_t,
+[AC_TRY_RUN([#include <stdio.h>
+#include <time.h>
+main()
+{
+ FILE *f=fopen("conftestval", "w");
+ if (!f) exit(1);
+ fprintf(f, "%d\n", sizeof(time_t));
+ exit(0);
+}], ac_cv_sizeof_time_t=`cat conftestval`, ac_cv_sizeof_time_t=0)
+])
+AC_MSG_RESULT($ac_cv_sizeof_time_t)
+AC_DEFINE_UNQUOTED(SIZEOF_TIME_T, $ac_cv_sizeof_time_t)
+
# Minor variations in building a framework between NextStep versions 4 and 5
AC_SUBST(LIBTOOL_CRUFT)