summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2003-11-18 20:00:44 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2003-11-18 20:00:44 (GMT)
commitc19c5a62aef7dce0e8147655b0d2f087965fae75 (patch)
treed1fe2605470b7df4b6d6b449290185e07b445d3d /configure.in
parente3be8606195bda506272e71544e34520799711b5 (diff)
downloadcpython-c19c5a62aef7dce0e8147655b0d2f087965fae75.zip
cpython-c19c5a62aef7dce0e8147655b0d2f087965fae75.tar.gz
cpython-c19c5a62aef7dce0e8147655b0d2f087965fae75.tar.bz2
Patch #836434: Use dlopen/dlsym on AIX if available. Also disable
_XOPEN_SOURCE on AIX 4.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c567d21..e0dd64d 100644
--- a/configure.in
+++ b/configure.in
@@ -156,6 +156,11 @@ case $ac_sys_system/$ac_sys_release in
# This should hopefully be fixed in FreeBSD 4.9
FreeBSD/4.8* | Darwin/6* )
define_xopen_source=no;;
+ # On AIX 4, mbstate_t is defined only when _XOPEN_SOURCE == 500 but used in
+ # wcsnrtombs() and mbsnrtowcs() even if _XOPEN_SOURCE is not defined or
+ # has another value. By not (re)defining it, the defaults come in place.
+ AIX/4)
+ define_xopen_source=no;;
esac
if test $define_xopen_source = yes
@@ -2036,7 +2041,12 @@ AC_MSG_CHECKING(DYNLOADFILE)
if test -z "$DYNLOADFILE"
then
case $ac_sys_system/$ac_sys_release in
- AIX*) DYNLOADFILE="dynload_aix.o";;
+ AIX*) # Use dynload_shlib.c and dlopen() if we have it; otherwise dynload_aix.c
+ if test "$ac_cv_func_dlopen" = yes
+ then DYNLOADFILE="dynload_shlib.o"
+ else DYNLOADFILE="dynload_aix.o"
+ fi
+ ;;
BeOS*) DYNLOADFILE="dynload_beos.o";;
hp*|HP*) DYNLOADFILE="dynload_hpux.o";;
Darwin/*) DYNLOADFILE="dynload_next.o";;