summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNeal Norwitz <nnorwitz@gmail.com>2006-03-20 06:30:08 (GMT)
committerNeal Norwitz <nnorwitz@gmail.com>2006-03-20 06:30:08 (GMT)
commit05a45599d7c7e7584a80d7ef70dc47e984664619 (patch)
tree67d35b00825fa7ab92cb32bf9db4ff902259c324 /configure.in
parent910b5eec07543dc4e7f4f35648a025fe7b032249 (diff)
downloadcpython-05a45599d7c7e7584a80d7ef70dc47e984664619.zip
cpython-05a45599d7c7e7584a80d7ef70dc47e984664619.tar.gz
cpython-05a45599d7c7e7584a80d7ef70dc47e984664619.tar.bz2
Patch #1309579: wait3 and wait4 were added to the posix module by Chad J. Schroeder.
This was a fair amount of rework of the patch. Refactored test_fork1 so it could be reused by the new tests for wait3/4. Also made them into new style unittests (derive from unittest.TestCase).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d617108..5d9ec56 100644
--- a/configure.in
+++ b/configure.in
@@ -2148,7 +2148,7 @@ AC_CHECK_FUNCS(alarm bind_textdomain_codeset chown clock confstr ctermid \
setlocale setregid setreuid setsid setpgid setpgrp setuid setvbuf snprintf \
sigaction siginterrupt sigrelse strftime \
sysconf tcgetpgrp tcsetpgrp tempnam timegm times tmpfile tmpnam tmpnam_r \
- truncate uname unsetenv utimes waitpid wcscoll _getpty)
+ truncate uname unsetenv utimes waitpid wait3 wait4 wcscoll _getpty)
# For some functions, having a definition is not sufficient, since
# we want to take their address.