summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2006-05-14 19:56:34 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2006-05-14 19:56:34 (GMT)
commit836b039b7cbcf99dd0864dcdffa30ef66a81d819 (patch)
tree840c0b4da42ed45831769fff68b9040fdf910f87 /configure.in
parent375f06b1755b712dcb1868fb32ee86dd317552f5 (diff)
downloadcpython-836b039b7cbcf99dd0864dcdffa30ef66a81d819.zip
cpython-836b039b7cbcf99dd0864dcdffa30ef66a81d819.tar.gz
cpython-836b039b7cbcf99dd0864dcdffa30ef66a81d819.tar.bz2
Rework the build system for osx applications:
* Don't use xcodebuild for building PythonLauncher, but use a normal unix makefile. This makes it a lot easier to use the same build flags as for the rest of python (e.g. make a universal version of python launcher) * Convert the mac makefile-s to makefile.in-s and use configure to set makefile variables instead of forwarding them as command-line arguments * Add a C version of pythonw, that we you can use '#!/usr/local/bin/pythonw' * Build IDLE.app using bundlebuilder instead of BuildApplet, that will allow easier modification of the bundle contents later on.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 168c621..8b82841 100644
--- a/configure.in
+++ b/configure.in
@@ -105,6 +105,12 @@ AC_ARG_ENABLE(framework,
PYTHONFRAMEWORKPREFIX=$enableval
PYTHONFRAMEWORKINSTALLDIR=$PYTHONFRAMEWORKPREFIX/$PYTHONFRAMEWORKDIR
prefix=$PYTHONFRAMEWORKINSTALLDIR/Versions/$VERSION
+
+ # Add makefiles for Mac specific code to the list of output
+ # files:
+ AC_CONFIG_FILES(Mac/OSX/Makefile)
+ AC_CONFIG_FILES(Mac/OSX/PythonLauncher/Makefile)
+ AC_CONFIG_FILES(Mac/OSX/IDLE/Makefile)
esac
],[
PYTHONFRAMEWORK=