summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1997-10-08 22:47:52 (GMT)
committerGuido van Rossum <guido@python.org>1997-10-08 22:47:52 (GMT)
commit9601315140cc505e17318d766e0bedec91e6b9ec (patch)
tree3e06941b715a5674fe1235b9648609311e624b98 /configure.in
parent1f14ccf6d1dc4e4f5142ef8d061f9080d17b16fe (diff)
downloadcpython-9601315140cc505e17318d766e0bedec91e6b9ec.zip
cpython-9601315140cc505e17318d766e0bedec91e6b9ec.tar.gz
cpython-9601315140cc505e17318d766e0bedec91e6b9ec.tar.bz2
Add checks for setlocale() and <locale.h>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 640969e..2343f74 100644
--- a/configure.in
+++ b/configure.in
@@ -167,7 +167,7 @@ AC_MSG_RESULT($cpp_type)
# checks for header files
AC_HEADER_STDC
-AC_CHECK_HEADERS(dlfcn.h fcntl.h limits.h ncurses.h pthread.h \
+AC_CHECK_HEADERS(dlfcn.h fcntl.h limits.h locale.h ncurses.h pthread.h \
signal.h stdarg.h stddef.h stdlib.h thread.h unistd.h utime.h \
sys/audioio.h sys/file.h sys/lock.h \
sys/param.h sys/select.h sys/time.h sys/times.h \
@@ -382,7 +382,7 @@ LIBS="$LIBS -ldl -ldld"], AC_MSG_RESULT(no))
AC_CHECK_FUNCS(alarm chown clock dlopen execv flock fork ftime ftruncate \
gethostname_r getpeername getpgrp getpid getpwent gettimeofday getwd \
kill link lstat mkfifo nice pause plock putenv readlink \
- select setgid setuid setsid setpgid setpgrp setvbuf \
+ select setgid setlocale setuid setsid setpgid setpgrp setvbuf \
sigaction siginterrupt sigrelse strftime symlink \
tcgetpgrp tcsetpgrp times truncate uname waitpid)
AC_REPLACE_FUNCS(dup2 getcwd strdup strerror memmove)