summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNeal Norwitz <nnorwitz@gmail.com>2005-12-15 05:25:09 (GMT)
committerNeal Norwitz <nnorwitz@gmail.com>2005-12-15 05:25:09 (GMT)
commita716eabca79f5da1605d758654b74798b90931d9 (patch)
treecb333c9e506fc6bef075058ff5b848d6b4677168 /configure.in
parentb1975436808898d7588a00adec33524bb561089f (diff)
downloadcpython-a716eabca79f5da1605d758654b74798b90931d9.zip
cpython-a716eabca79f5da1605d758654b74798b90931d9.tar.gz
cpython-a716eabca79f5da1605d758654b74798b90931d9.tar.bz2
Revert r41662 and the part of 41552 that originally caused the problem
(calling ftell(stdin) doesn't seem defined). So we won't test errors from ftell unless we can do it portably.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 0 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index 0550e4f..75a33a1 100644
--- a/configure.in
+++ b/configure.in
@@ -2955,28 +2955,6 @@ then
[Define if poll() sets errno on invalid file descriptors.])
fi
-AC_MSG_CHECKING(for broken ftell())
-AC_CACHE_VAL(ac_cv_broken_ftell, [
-AC_TRY_RUN([
-#include <stdio.h>
-int main()
-{
- long val = ftell(stdin);
- if (val != -1)
- exit(0);
- exit(1);
-}
-],
-ac_cv_broken_ftell=yes,
-ac_cv_broken_ftell=no,
-ac_cv_broken_ftell=no)])
-AC_MSG_RESULT($ac_cv_broken_ftell)
-if test "$ac_cv_broken_ftell" = yes
-then
- AC_DEFINE(HAVE_BROKEN_FTELL, 1,
- [Define if ftell() set errno on tty files.])
-fi
-
# Before we can test tzset, we need to check if struct tm has a tm_zone
# (which is not required by ISO C or UNIX spec) and/or if we support
# tzname[]