summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2003-12-08 01:10:12 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2003-12-08 01:10:12 (GMT)
commitc8607b76f0465d91998add0c3b13be59b7a4bce7 (patch)
treea4dd088ef1f7bbe582f7225e2bf5fe0dd862079f /configure.in
parent48e02e4c395c6119b6f6240593607103d4300ff3 (diff)
downloadcpython-c8607b76f0465d91998add0c3b13be59b7a4bce7.zip
cpython-c8607b76f0465d91998add0c3b13be59b7a4bce7.tar.gz
cpython-c8607b76f0465d91998add0c3b13be59b7a4bce7.tar.bz2
Revamped framework search path handling for MacOSX. This should allow
two framework builds (in /Library and /System/Library) to coexist with distutils linking against the right one. Should be backported to 2.3, but getting Apple-supplied Python to pick up these fixes is going to be non-trivial.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index e0dd64d..9a4183c 100644
--- a/configure.in
+++ b/configure.in
@@ -1185,7 +1185,6 @@ then
BASECFLAGS="$BASECFLAGS -fno-common -dynamic"
# -F. is needed to allow linking to the framework while
# in the build location.
- LDFLAGS="$LDFLAGS -Wl,-F."
AC_DEFINE(WITH_NEXT_FRAMEWORK, 1,
[Define if you want to produce an OpenStep/Rhapsody framework
(shared library plus accessory files).])
@@ -1268,7 +1267,8 @@ then
LDSHARED='$(CC) $(LDFLAGS) -bundle'
if test "$enable_framework" ; then
# Link against the framework. All externals should be defined.
- LDSHARED="$LDSHARED "'-framework $(PYTHONFRAMEWORK)'
+ BLDSHARED="$LDSHARED "'-Wl,-F. -framework $(PYTHONFRAMEWORK)'
+ LDSHARED="$LDSHARED "'-Wl,-F$(PYTHONFRAMEWORKPREFIX) -framework $(PYTHONFRAMEWORK)'
else
# No framework. Ignore undefined symbols, assuming they come from Python
LDSHARED="$LDSHARED -undefined suppress"
@@ -1277,7 +1277,8 @@ then
LDSHARED='$(CC) $(LDFLAGS) -bundle'
if test "$enable_framework" ; then
# Link against the framework. All externals should be defined.
- LDSHARED="$LDSHARED "'-framework $(PYTHONFRAMEWORK)'
+ BLDSHARED="$LDSHARED "'-Wl,-F. -framework $(PYTHONFRAMEWORK)'
+ LDSHARED="$LDSHARED "'-Wl,-F$(PYTHONFRAMEWORKPREFIX) -framework $(PYTHONFRAMEWORK)'
else
# No framework, use the Python app as bundle-loader
BLDSHARED="$LDSHARED "'-bundle_loader $(BUILDPYTHON)'
@@ -1370,7 +1371,7 @@ then
LINKFORSHARED="$extra_undefs -framework System"
if test "$enable_framework"
then
- LINKFORSHARED="$LINKFORSHARED -framework Python"
+ LINKFORSHARED="$LINKFORSHARED -Wl,-F. -framework Python"
fi
LINKFORSHARED="$LINKFORSHARED $extra_frameworks";;
OpenUNIX*|UnixWare*) LINKFORSHARED="-Wl,-Bexport";;