summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2009-12-31 21:11:48 (GMT)
committerMark Dickinson <dickinsm@gmail.com>2009-12-31 21:11:48 (GMT)
commit0ef0b910ce974f296667671ec7d34783ea1d9bd0 (patch)
tree9e84c81eda7cc9718e3fcc2c514642d70b85ba3e /configure.in
parent5ce8474cc7e8fb602943b0ecd60cbcbc2d3b2a41 (diff)
downloadcpython-0ef0b910ce974f296667671ec7d34783ea1d9bd0.zip
cpython-0ef0b910ce974f296667671ec7d34783ea1d9bd0.tar.gz
cpython-0ef0b910ce974f296667671ec7d34783ea1d9bd0.tar.bz2
More configure fixes: avoid sh 'integer argument expected' error when 'long long' type doesn't exist.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 8f7d28a..637490b 100644
--- a/configure.in
+++ b/configure.in
@@ -1457,8 +1457,9 @@ AC_CHECK_SIZEOF(off_t, [], [
])
AC_MSG_CHECKING(whether to enable large file support)
-if test "$have_long_long" = yes -a \
- "$ac_cv_sizeof_off_t" -gt "$ac_cv_sizeof_long" -a \
+if test "$have_long_long" = yes
+then
+if test "$ac_cv_sizeof_off_t" -gt "$ac_cv_sizeof_long" -a \
"$ac_cv_sizeof_long_long" -ge "$ac_cv_sizeof_off_t"; then
AC_DEFINE(HAVE_LARGEFILE_SUPPORT, 1,
[Defined to enable large file support when an off_t is bigger than a long
@@ -1469,6 +1470,9 @@ if test "$have_long_long" = yes -a \
else
AC_MSG_RESULT(no)
fi
+else
+ AC_MSG_RESULT(no)
+fi
AC_CHECK_SIZEOF(time_t, [], [
#ifdef HAVE_SYS_TYPES_H
@@ -2967,7 +2971,7 @@ int main()
ac_cv_buggy_getaddrinfo=yes))
fi
-if test $have_getaddrinfo = no -o $ac_cv_buggy_getaddrinfo = yes
+if test $have_getaddrinfo = no -o "$ac_cv_buggy_getaddrinfo" = yes
then
if test $ipv6 = yes
then