summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2001-12-06 21:47:20 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2001-12-06 21:47:20 (GMT)
commit1999ef4973fb0e02872c2d970e9690061b65412d (patch)
tree89bd5e3b2684153989fff6f853488dc98b7ce875 /configure.in
parent3ecc1ce529f24c69e90b270786cd3e43b300a274 (diff)
downloadcpython-1999ef4973fb0e02872c2d970e9690061b65412d.zip
cpython-1999ef4973fb0e02872c2d970e9690061b65412d.tar.gz
cpython-1999ef4973fb0e02872c2d970e9690061b65412d.tar.bz2
Test wether we are building on a case-insensitive filesystem (such
as OSX HFS+) and if so add an extension to the python executable, but only in the build directory, not on the installed python.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index e9c90ad..3a21ddb 100644
--- a/configure.in
+++ b/configure.in
@@ -198,11 +198,18 @@ AC_ARG_WITH(suffix, [ --with-suffix=.exe set executable suffix],[
*) EXEEXT=$withval;;
esac])
AC_MSG_RESULT($EXEEXT)
+
# Test whether we're running on a non-case-sensitive system, in which
# case we give a warning if no ext is given
-if test -d "python" -a -z "$EXEEXT"
+AC_SUBST(BUILDEXEEXT)
+AC_MSG_CHECKING(for case-insensitive build directory)
+if test -d "python"
then
- AC_MSG_WARN(This filesystem is not case-sensitive so you should probably use --with-suffix)
+ AC_MSG_RESULT(yes)
+ BUILDEXEEXT=.exe
+else
+ AC_MSG_RESULT(no)
+ BUILDEXEEXT='$(EXEEXT)'
fi
case $MACHDEP in