summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2009-11-19 16:25:21 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2009-11-19 16:25:21 (GMT)
commit315cd0c73939ff2b9a9dbef35986b129a0b3064e (patch)
treed4fdaacc67f9508f0b814a8f614e4ac7c9a0e358 /configure.in
parent39de1fc5c8715fa69d96501e100b360c3b56d22e (diff)
downloadcpython-315cd0c73939ff2b9a9dbef35986b129a0b3064e.zip
cpython-315cd0c73939ff2b9a9dbef35986b129a0b3064e.tar.gz
cpython-315cd0c73939ff2b9a9dbef35986b129a0b3064e.tar.bz2
Fix for issue #7085
On MacOSX 10.6 the CoreFoundation framework must be initialized on the main thread, the constructor function in that framework will cause an SIGABRT when it is called on any other thread. Because a number of extension link (indirectly) to CoreFoundation and the Python core itself didn't the interpreter crashed when importing some extensions, such as _locale, on a secondary thread. This fix ensures that Python is linked to CoreFoundation on OSX, which results in the CoreFoundation constructor being called when Python is loaded. This does not require code changes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fe8bb2b..c3a1678 100644
--- a/configure.in
+++ b/configure.in
@@ -3999,6 +3999,11 @@ then
[Define to printf format modifier for long long type])
fi
+if test $ac_sys_system = Darwin
+then
+ LIBS="$LIBS -framework CoreFoundation"
+fi
+
AC_CACHE_CHECK([for %zd printf() format support], ac_cv_have_size_t_format, [dnl
AC_TRY_RUN([