summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1997-01-22 20:51:58 (GMT)
committerGuido van Rossum <guido@python.org>1997-01-22 20:51:58 (GMT)
commit54d93d446bed87a8ceea9c48ac84820a19a62344 (patch)
tree62fbddf26ba981d3e41bafc08b73c7a78b5b42ea /configure.in
parente0e696282feea175d82920e0cf13e90bd7a9252e (diff)
downloadcpython-54d93d446bed87a8ceea9c48ac84820a19a62344.zip
cpython-54d93d446bed87a8ceea9c48ac84820a19a62344.tar.gz
cpython-54d93d446bed87a8ceea9c48ac84820a19a62344.tar.bz2
Add --with-dec-threads, for DEL Alpha, which requires -threads as the
*final* linker argument. This implies --with-thread. Reimplemented --with-threads as an alias for --with-thread.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 19 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 34113ca..92b1892 100644
--- a/configure.in
+++ b/configure.in
@@ -305,13 +305,26 @@ then
fi
fi
-AC_MSG_CHECKING(for --with-thread)
-# Let --with-threads be an alias for --with-thread
+AC_MSG_CHECKING(for --with-dec-threads)
+AC_SUBST(LDLAST)
+AC_ARG_WITH(dec-threads,
+[--with-dec-threads use DEC Alpha/OSF1 thread-safe libraries],
+[AC_MSG_RESULT($withval)
+LDLAST=-threads
if test "${with_thread+set}" != set; then
- if test "${with_threads+set}" = set; then
- with_thread="$with_threads";
- fi
-fi
+ with_thread="$withval";
+fi],
+AC_MSG_RESULT(no))
+
+AC_MSG_CHECKING(for --with-threads)
+AC_ARG_WITH(threads, [--with-threads alias for --with-thread],
+[AC_MSG_RESULT($withval)
+if test "${with_thread+set}" != set; then
+ with_thread="$withval";
+fi],
+AC_MSG_RESULT(no))
+
+AC_MSG_CHECKING(for --with-thread)
AC_ARG_WITH(thread, [--with-thread[=DIRECTORY] make interpreter thread-safe], [
AC_MSG_RESULT($withval)
if test -d "$withval"