summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2009-12-13 21:06:06 (GMT)
committerMark Dickinson <dickinsm@gmail.com>2009-12-13 21:06:06 (GMT)
commit59dc89e87d6ab7ecff74a3fd215312f551b58f63 (patch)
tree3c0a6d19ab77d7df258608ca8fa5dc6c47ad443f /configure.in
parentaef189939e084ff20b22841f31d71cd12236af60 (diff)
downloadcpython-59dc89e87d6ab7ecff74a3fd215312f551b58f63.zip
cpython-59dc89e87d6ab7ecff74a3fd215312f551b58f63.tar.gz
cpython-59dc89e87d6ab7ecff74a3fd215312f551b58f63.tar.bz2
Issue #7492: Autoconf tests were leaving semaphore files behind. Add
sem_unlink calls to delete those semaphore files.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a395c97..7632646 100644
--- a/configure.in
+++ b/configure.in
@@ -3455,6 +3455,7 @@ int main(void) {
return 1;
}
sem_close(a);
+ sem_unlink("/autoconf");
return 0;
}
], ac_cv_posix_semaphores_enabled=yes,
@@ -3479,7 +3480,7 @@ AC_TRY_RUN([
#include <sys/stat.h>
int main(void){
- sem_t *a = sem_open("/autoconf", O_CREAT, S_IRUSR|S_IWUSR, 0);
+ sem_t *a = sem_open("/autocftw", O_CREAT, S_IRUSR|S_IWUSR, 0);
int count;
int res;
if(a==SEM_FAILED){
@@ -3489,6 +3490,7 @@ int main(void){
}
res = sem_getvalue(a, &count);
sem_close(a);
+ sem_unlink("/autocftw");
return res==-1 ? 1 : 0;
}
], ac_cv_broken_sem_getvalue=no,