summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2001-09-07 14:25:12 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2001-09-07 14:25:12 (GMT)
commita3891ea46c6d7352171b6f1eae9df1240cb58738 (patch)
treee7d0702985b8f41777bf57ae17f6579ae244f119 /configure.in
parent19fdbfb5c49bd7fbbc4f1899ee9c649cfb22fdb8 (diff)
downloadcpython-a3891ea46c6d7352171b6f1eae9df1240cb58738.zip
cpython-a3891ea46c6d7352171b6f1eae9df1240cb58738.tar.gz
cpython-a3891ea46c6d7352171b6f1eae9df1240cb58738.tar.bz2
(Slightly modified) patch by Steve Spicklemire to make Python build
out of the box on OSX 10.1. Untested by me (except for not having adverse effects on 10.0.4) but it looks good, for now. Eventually we should not trigger on the darwin version but test for something, but until I have the time to install 10.1 myself I have no clue what to test on. It would be nice if this got in to the 2.2a3 distribution.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c13e848..eb57011 100644
--- a/configure.in
+++ b/configure.in
@@ -582,6 +582,12 @@ AC_MSG_RESULT($enable_toolbox_glue)
AC_SUBST(LIBTOOL_CRUFT)
case $ac_sys_system/$ac_sys_release in
+ Darwin/1.4*)
+ ns_undef_sym='_environ'
+ LIBTOOL_CRUFT="-lcc_dynamic -arch_only ppc -flat_namespace -U $ns_undef_sym"
+ LIBTOOL_CRUFT="$LIBTOOL_CRUFT $extra_frameworks"
+ LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKDIR)/Versions/$(VERSION)/Python'
+ LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
Darwin/*)
ns_undef_sym='_environ'
LIBTOOL_CRUFT="-lcc_dynamic -arch_only ppc -U $ns_undef_sym"
@@ -599,7 +605,10 @@ then
# -F. is needed to allow linking to the framework while
# in the build location.
- LDFLAGS="$LDFLAGS -Wl,-F. -Wl,-U,$ns_undef_sym"
+ case $ac_sys_system/$ac_sys_release in
+ Darwin/1.4*)LDFLAGS="$LDFLAGS -Wl,-F. -Wl,-flat_namespace,-U,$ns_undef_sym";;
+ Darwin/*)LDFLAGS="$LDFLAGS -Wl,-F. -Wl,-U,$ns_undef_sym";;
+ esac
AC_DEFINE(WITH_NEXT_FRAMEWORK)
AC_MSG_RESULT(yes)
else
@@ -662,6 +671,15 @@ then
hp*|HP*) LDSHARED="ld -b";;
OSF*) LDSHARED="ld -shared -expect_unresolved \"*\"";;
DYNIX/ptx*) LDSHARED="ld -G";;
+ Darwin/1.4*)
+ LDSHARED='$(CC) $(LDFLAGS) -bundle'
+ if test "$enable_framework" ; then
+ # Link against the framework. All externals should be defined.
+ LDSHARED="$LDSHARED "'-framework $(PYTHONFRAMEWORK)'
+ else
+ # No framework. Ignore undefined symbols, assuming they come from Python
+ LDSHARED="$LDSHARED -flat_namespace -undefined suppress"
+ fi ;;
Darwin/*)
LDSHARED='$(CC) $(LDFLAGS) -bundle'
if test "$enable_framework" ; then