summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1996-07-31 17:35:03 (GMT)
committerGuido van Rossum <guido@python.org>1996-07-31 17:35:03 (GMT)
commitc5a39034727cc193f891c5a75475dab550c9feac (patch)
tree6d3c8d5a8ddb1e91dd65511b97487b782dee4a19 /configure.in
parentbed23fe1ceb8313b8f911d30ced82e6eef6f9145 (diff)
downloadcpython-c5a39034727cc193f891c5a75475dab550c9feac.zip
cpython-c5a39034727cc193f891c5a75475dab550c9feac.tar.gz
cpython-c5a39034727cc193f891c5a75475dab550c9feac.tar.bz2
Three changes:
- Improved version of NeXT patching of $OPT - Added new option --with-libs='lib1 lib2 ...' - Define _REENTRANT when posix threads are in use
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 12 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index a5ddbed..dde8520 100644
--- a/configure.in
+++ b/configure.in
@@ -90,16 +90,15 @@ AC_SUBST(OPT)
if test -z "$OPT"
then
case $ac_sys_system in
- NeXT|next) \
- if test -n "$ac_arch_flags"; then
- OPT="-g -Wall -O3 -fomit-frame-pointer $ac_arch_flags";
- else
- OPT="-g -Wall -O3 -fomit-frame-pointer";
- fi;;
+ NeXT|next) OPT="-g -Wall -O3 -fomit-frame-pointer";;
*) OPT="-O";;
esac
fi
+if test -z "$ac_arch_flags"
+then
+ OPT="$OPT $ac_arch_flags"
+fi
# checks for UNIX variants that set C preprocessor variables
AC_AIX
AC_MINIX
@@ -205,6 +204,11 @@ AC_CHECK_LIB(nsl, t_open, [LIBS="-lnsl $LIBS"]) # SVR4
AC_CHECK_LIB(inet, gethostbyname, [LIBS="-linet $LIBS"], [], -lnsl) # Sequent
AC_CHECK_LIB(socket, socket, [LIBS="-lsocket $LIBS"], [], $LIBS) # SVR4 sockets
fi
+AC_MSG_CHECKING(for --with-libs)
+AC_ARG_WITH(libs, [--with-libs='lib1 ...' link against additional libs], [
+AC_MSG_RESULT($withval)
+LIBS="$withval $LIBS"
+], AC_MSG_RESULT(no))
# XXX need to check whether libreadline.a actually exists there!
# XXX Also, on some systems, it's libreadline.so...
@@ -242,10 +246,12 @@ AC_DEFINE(C_THREADS)
LIBOBJS="$LIBOBJS thread.o"],[
AC_CHECK_LIB(pthreads, pthread_create, [AC_DEFINE(WITH_THREAD)
AC_DEFINE(_POSIX_THREADS)
+AC_DEFINE(_REENTRANT)
LIBS="$LIBS -lpthreads"
LIBOBJS="$LIBOBJS thread.o"], [
AC_CHECK_LIB(pthread, pthread_create, [AC_DEFINE(WITH_THREAD)
AC_DEFINE(_POSIX_THREADS)
+AC_DEFINE(_REENTRANT)
LIBS="$LIBS -lpthread"
LIBOBJS="$LIBOBJS thread.o"])
])])