summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2010-05-05 22:23:58 (GMT)
committerMark Dickinson <dickinsm@gmail.com>2010-05-05 22:23:58 (GMT)
commitd2f3e3fc1df593423a69911ea84e4b0acd1edf1f (patch)
treeff3fa770c2d69ed1cb955621772e318a15079cbc /configure.in
parent38f81223ae3e26933faeef1e697d5e4ac978cf45 (diff)
downloadcpython-d2f3e3fc1df593423a69911ea84e4b0acd1edf1f.zip
cpython-d2f3e3fc1df593423a69911ea84e4b0acd1edf1f.tar.gz
cpython-d2f3e3fc1df593423a69911ea84e4b0acd1edf1f.tar.bz2
Issue #8625: Turn off gcc optimization in debug builds.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4def2d4..2149683 100644
--- a/configure.in
+++ b/configure.in
@@ -942,7 +942,7 @@ then
if test "$Py_DEBUG" = 'true' ; then
# Optimization messes up debuggers, so turn it off for
# debug builds.
- OPT="-g -Wall $STRICT_PROTO"
+ OPT="-g -O0 -Wall $STRICT_PROTO"
else
OPT="-g $WRAP -O3 -Wall $STRICT_PROTO"
fi