summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGregory P. Smith <greg@mad-scientist.com>2009-11-02 02:02:38 (GMT)
committerGregory P. Smith <greg@mad-scientist.com>2009-11-02 02:02:38 (GMT)
commitd8cb2d9c594eecbde2e29851948b86a8d587966e (patch)
tree658516ebaca50f7b14aad17e4623e89f0bd855b7 /configure.in
parent49437c20fd3636a0e204440cfd048b34afa50f24 (diff)
downloadcpython-d8cb2d9c594eecbde2e29851948b86a8d587966e.zip
cpython-d8cb2d9c594eecbde2e29851948b86a8d587966e.tar.gz
cpython-d8cb2d9c594eecbde2e29851948b86a8d587966e.tar.bz2
see issue1006238, this merges in the following patch to ease cross
compiling the printf %zd check. http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-lang/python/files/python-2.5-cross-printf.patch?rev=1.1&view=markup
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 6 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 58a18d3..6c5add3 100644
--- a/configure.in
+++ b/configure.in
@@ -3953,9 +3953,8 @@ else
AC_MSG_RESULT(no)
fi
-AC_MSG_CHECKING(for %zd printf() format support)
-AC_CACHE_VAL(ac_cv_have_size_t_format,
-AC_TRY_RUN([[
+AC_CACHE_CHECK([for %zd printf() format support], ac_cv_have_size_t_format, [dnl
+AC_TRY_RUN([
#include <stdio.h>
#include <stddef.h>
#include <string.h>
@@ -3990,13 +3989,11 @@ int main()
return 0;
}
-]], ac_cv_have_size_t_format=yes,
+], ac_cv_have_size_t_format=yes,
ac_cv_have_size_t_format=no,
- ac_cv_have_size_t_format=no)
-)
-AC_MSG_RESULT($ac_cv_have_size_t_format)
-if test $ac_cv_have_size_t_format = yes
-then
+ [ac_cv_have_size_t_format="cross -- assuming yes"]
+)])
+if test "$ac_cv_have_size_t_format" != no ; then
AC_DEFINE(PY_FORMAT_SIZE_T, "z",
[Define to printf format modifier for Py_ssize_t])
fi