summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFred Drake <fdrake@acm.org>2001-12-04 20:55:47 (GMT)
committerFred Drake <fdrake@acm.org>2001-12-04 20:55:47 (GMT)
commite1ceaa00dcff79db261e2c833880d3c82771c91b (patch)
treeb05d99dd9a87411d8571d37d590e0749edcea725 /configure.in
parent4ed6be710752a6f61f16170b1f5198263da1429b (diff)
downloadcpython-e1ceaa00dcff79db261e2c833880d3c82771c91b.zip
cpython-e1ceaa00dcff79db261e2c833880d3c82771c91b.tar.gz
cpython-e1ceaa00dcff79db261e2c833880d3c82771c91b.tar.bz2
Define NDEBUG when compiling a release build on Unix.
This is the Unix portion of the fix for SF bug #489052.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index adfb2fd..09aa5de 100644
--- a/configure.in
+++ b/configure.in
@@ -389,6 +389,12 @@ then
esac
fi
+if test "$Py_DEBUG" = 'true'; then
+ :
+else
+ OPT="-DNDEBUG $OPT"
+fi
+
# The current (beta) Monterey compiler dies with optimizations
case $ac_sys_system in
Monterey*) OPT="";;