summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2010-03-14 14:24:31 (GMT)
committerBenjamin Peterson <benjamin@python.org>2010-03-14 14:24:31 (GMT)
commit11d932372bab6b409e48116ec90311f36c0a9efd (patch)
tree1f6752e749d0d201b72beee89f2922e8e610a36b /configure.in
parent8122bdd8bd6f0f84a7e296190a510431888aa274 (diff)
downloadcpython-11d932372bab6b409e48116ec90311f36c0a9efd.zip
cpython-11d932372bab6b409e48116ec90311f36c0a9efd.tar.gz
cpython-11d932372bab6b409e48116ec90311f36c0a9efd.tar.bz2
fix freebsd linking #7705
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0fadd75..20e54fc 100644
--- a/configure.in
+++ b/configure.in
@@ -1829,7 +1829,7 @@ then
FreeBSD*)
if [[ "`$CC -dM -E - </dev/null | grep __ELF__`" != "" ]]
then
- LDSHARED="$CC -shared ${LDFLAGS}"
+ LDSHARED="$(CC) -shared ${LDFLAGS}"
else
LDSHARED="ld -Bshareable ${LDFLAGS}"
fi;;