summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2006-02-23 15:12:19 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2006-02-23 15:12:19 (GMT)
commit39fd2317016371bbcf3c3861ffe66f980d6eab1c (patch)
tree707dc0c4b284e803a03193b399328719a5162b5f /configure.in
parent81ae235146a058446e5a2ff8b2722686b9e36cc3 (diff)
downloadcpython-39fd2317016371bbcf3c3861ffe66f980d6eab1c.zip
cpython-39fd2317016371bbcf3c3861ffe66f980d6eab1c.tar.gz
cpython-39fd2317016371bbcf3c3861ffe66f980d6eab1c.tar.bz2
On OSX, use --arch_only `arch` in stead of --arch_only ppc, so things will
build for the current CPU.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ea2dcbd..d617108 100644
--- a/configure.in
+++ b/configure.in
@@ -1265,7 +1265,7 @@ esac
AC_SUBST(LIBTOOL_CRUFT)
case $ac_sys_system/$ac_sys_release in
Darwin/@<:@01234567@:>@.*)
- LIBTOOL_CRUFT="-framework System -lcc_dynamic -arch_only ppc"
+ LIBTOOL_CRUFT="-framework System -lcc_dynamic -arch_only `arch`"
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKINSTALLDIR)/Versions/$(VERSION)/$(PYTHONFRAMEWORK)'
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
Darwin/*)
@@ -1276,7 +1276,7 @@ case $ac_sys_system/$ac_sys_release in
else
LIBTOOL_CRUFT=""
fi
- LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -lSystem -lSystemStubs -arch_only ppc'
+ LIBTOOL_CRUFT=$LIBTOOL_CRUFT" -lSystem -lSystemStubs -arch_only `arch`"
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKINSTALLDIR)/Versions/$(VERSION)/$(PYTHONFRAMEWORK)'
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
esac