summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2011-03-06 09:42:21 (GMT)
committerGeorg Brandl <georg@python.org>2011-03-06 09:42:21 (GMT)
commit3a5508e2c075405f35b5c32f413445b9e875c92c (patch)
tree784515c9e36589fddb6311168278ff332a5cd92c /configure.in
parent93512f24f1374ef83ac3cca21881b4eea5173781 (diff)
downloadcpython-3a5508e2c075405f35b5c32f413445b9e875c92c.zip
cpython-3a5508e2c075405f35b5c32f413445b9e875c92c.tar.gz
cpython-3a5508e2c075405f35b5c32f413445b9e875c92c.tar.bz2
Port build identification from default branch.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d082191..ea106b5 100644
--- a/configure.in
+++ b/configure.in
@@ -853,6 +853,21 @@ else
SVNVERSION="echo Unversioned directory"
fi
+AC_SUBST(HGVERSION)
+AC_SUBST(HGTAG)
+AC_SUBST(HGBRANCH)
+AC_CHECK_PROG(HAS_HG, hg, found, not-found)
+if test $HAS_HG = found
+then
+ HGVERSION="hg id -i \$(srcdir)"
+ HGTAG="hg id -t \$(srcdir)"
+ HGBRANCH="hg id -b \$(srcdir)"
+else
+ HGVERSION=""
+ HGTAG=""
+ HGBRANCH=""
+fi
+
case $MACHDEP in
bsdos*|hp*|HP*)
# install -d does not work on BSDI or HP-UX